‘Shutdown’ or ‘Shut Down’?

Which one is correct?


I’m not quite sure. Seems many Windows API calls reference it as Shutdown. Not being convinced, I did a Google search, and found an article on The Old New Thing that summarizes why there is confusion.

Basically, it boils down to this:

shutdown = noun

shut down = verb

So, my method is called ShutDown, because methods should be action phrases (verbs). The enum value will be Shutdown, because that’s a noun (the state of something).

Who says all those grammar classes in grade school don’t apply to programming?